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Introduction 
 
The purpose of this workshop and booklet is to help students understand the process 
involved with creating and publishing web pages. We will be using a web page editing 
program called Dreamweaver 8.  
 

Note: You must have activated your NetID before you can publish a web 
page to the students’ server , if you don’t have a NetID, you can go to 
http://netid.kennesaw.edu to activate your NetID. 

  
Creating - When creating and editing a web page using Dreamweaver, you are editing 
files that are on the computer in front of you.  This computer is referred to as the local 
computer.  You should create a folder on this local computer and keep all of the files 
related to your web site (pages, images, etc.) in this local folder.  In Dreamweaver, you 
look at the files in your local folder with the local view. 
 
Publishing - When you are finished with the files that make up your website, you will 
have to send these files to your account on the web server. This computer is referred to as 
the remote computer. The action of sending these files is called publishing to the server, 
FTPing the files, or uploading the files to the server. Dreamweaver calls this action 
“putting files to the remote server”.  In Dreamweaver, you look at the files on the web 
server with the remote view. 
 
Viewing - After publishing your web page files to the web server, you will want to check 
and see if they are working properly. To view your web site, open a web browser and 
enter your web address in the address bar. Your web address on the students server is 
http://students.kennesaw.edu/~yournetid. 
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Terms and Definitions 
 
Web page – a web page is a document file just like a text file. It can be edited with 
Notepad or WordPad if need be. The main difference between a web page and a regular 
text file is that a web page is formatted with html tags. This html formatting is what you 
see when you switch your web page from the Design view to the Code view.  
 
Web site – a web site is a collection of web pages that are usually linked together with 
hyperlinks. 
 
Hyperlink or Link– a section of text or image that appears colored and/or underlined on 
a web page that, when clicked, will take you to another web page. 
 
HTML – a text markup language consisting of tags. HTML tells the web browser how to 
display the content of your web page. 
 
Web server – a computer or host for your web site. If you are a student at KSU and have 
activated your NetID http://netid.kennesaw.edu, you have web space on the students 
server http://students.kennesaw.edu. 
 
Web browser – an application or program that is installed on your computer that allows 
you to view web pages on the Internet. 
 
Index page – the main page of your web site. This is the first page that people will see 
when they visit your site. When you create the index page you must save it as index.html. 
Note: index.html must be spelled with all lower case letters. 
 
Publish or FTP- when used as verbs these two words mean the same thing: to send or 
upload your web page or pages to your account on the web server. 
 
Web address – a URL (Uniform Resource Locator) is the text you type into the address 
bar of your web browser to access a web page. For example: http://www.cnn.com. Your 
web address on the students server is http://students.kennesaw.edu/~yournetID.  The 
“yournetID” in this address refers to your username for the student email system, 
WebCT, etc.  Do not put www in this address. 
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The Dreamweaver Environment 
 
Dreamweaver is an application that helps you to create, edit, and manage web pages and 
web sites.  Dreamweaver provides you with a WYSIWYG (what you see is what you get) 
editing environment.  In other words, while editing your page, it looks like it will when 
viewed by a web browser.  It also lets you easily switch over to see and edit the HTML 
code of your web page if you so desire.  Dreamweaver also provides a publishing tool 
that helps you easily manage your files both locally and on your web server. 
 
Panels - When you open the Dreamweaver application, one of the first things that you 
will notice is the panels. The panels are sections of Dreamweaver that give you different 
options of things that you can do to your web pages. 
 
To turn off the panels: 
Click on the Window menu or the View menu and then Hide Panels 
 
To turn on the panels: 
Click on the Window menu or the View menu and then Show Panels 
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Define a Site 
 
Before you can publish your web pages to your web site, you must create or define a Site. 
A Site in Dreamweaver is a collection of files and folders (web pages, images, etc) on 
your personal computer, and a link to your web space on the Internet.  As you create and 
edit your web pages, you will be working on files on this local Site. When your pages are 
finished and ready to be viewed on the Internet, Dreamweaver gives you the ability to 
put these files from your local Site onto your web space. 
 
Note: You must create a local folder for your web pages and have access to an account 
on a web server before you can define a Site. 
 
 
To define a Site: 
 

1. On the menu bar, select       
Site→ Manage Sites. This opens 
the Manage Sites window which 
lists any sites that have already 
been defined.   

 
2. Click on New → Site.  This will 

start the Site Definition wizard. 
 

3. Click on the Basic tab at the top 
of the Site Definition window. 

 
4. Type in a name for your Site  

 
5. Type in the HTTP Address, 

and click Next 
 

6. Select the “No, I do not to use 
server technology” radio 
button, and then click Next. 
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7. Select the “Edit local copies on 

my machine…” radio button. 
 

8. Click on the yellow folder icon 
further down on the page, and 
choose the folder on your 
computer where your local files 
will be saved and click the Next 
button. 

 
9. From the “How do you connect to 

your remote server?” drop-down 
window, choose FTP. 

 
10. In the “hostname or FTP address” 

text box, enter: 
“students.kennesaw.edu” 
 
Faculty and staff should enter “ksuweb.kennesaw.edu” for the FTP address, 
and use their kusweb ID and password in the FTP login area. 

 
11. In the “What folder on the server…” text box, enter “html/”.  It is important that 

this be exactly as shown in the 
picture, or else it may not work 
properly. 

 
12. In the “FTP login” text box, 

enter your NETID. 
 

13. In the “FTP password” text 
box, enter your NETID 
Password. 

 
14. You can test the connection by 

clicking on the Test 
Connection button. 

 
15. Uncheck the Save check box so 

that other students using the 
computer you are sitting at will 
not have access to your web 
space. 

 
16. If you get a message saying 

that Dreamweaver connected successfully, click the Next button. 
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17. Select the “Do not enable check in and check out” radio button click the Next 

button. 
 

18. In the Summary Screen Make sure all of your information is correct, and then 
click the Done button. 

 
19. When you return to the Manage Sites window, click the Done button. 

 
To see your site and all of the files that it contains, open the Files panel from the right 
side of the main Dreamweaver screen. You should be able to see all of your Sites in the 
left drop-down menu.  The right drop-down menu allows you to toggle the local and 
remote views, as well as offering a few more advanced views. 
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Creating a New Page 
 
Once you have created a Site which links your local computer and your remote web 
server, you then need to create one or more web pages.  The first step in doing this is to 
create a new page.   
 

1) Click File → New. 
2) From the Category column, make sure that Basic page is selected. 
3) From the Basic Page column, make sure that HTML is selected. 
4) Click the Create button.  This should open a new blank HTML document. 
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Page Properties 
 
Background color 
 

1. Click the Page Properties button on the extended Properties toolbar. 
 

 
 

2. In the Page Properties dialog box, select Appearance in the Category list. 
 

 
 

3. In the Appearance section, click the Background color button. 
4. Select the color of your choice from the color palette. 
 

*NOTE:  A good utility when choosing color schemes is located at 
http://www.sessions.edu/ilu/ 

 
Default Text Settings 
 

1. While still in the Appearance section of the Page Properties dialog box, make the 
selections of your choice from the Page Font, Size, and Text color options. 

2. Click OK. 
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Formatting Text 
 

1. Select the text you want to format. 
2. Make the formatting selections of your choice from the fields and buttons on the 

Properties toolbar (Format, Font, Size, Bold, etc.) 
 

Adding Graphics to the Web Page 
 
Downloading an Image 
 
You can get pictures and other graphic images from a variety of locations---websites, 
scanned images, clipart files, etc. 
 
To down load an image from a website: 
 
1. Place the mouse pointer on the image and click the right mouse button.  This menu 

will appear: 
 
 
 
 
 
 
 
 
 
 
 

 
2. Left-click Save Image As. 

 
3. In the Save As dialog box, indicate where you want to save the image in the Save in 

area. 
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4. The name of the file will be displayed in the File name area.  If you want, you can 
change the filename. 

 
5. The type of file (GIF, JPEG, etc.) will be displayed in the Save as type area. 
 
6. Click Save. 
Inserting an Image 
 
 

1. Click Insert Image. 
 

 
 

2. In the Look in field, navigate to the location of the image file and select the 
image. 

 
3. Click OK.  The following message will appear: 
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4. Click OK.  The following message may appear: 

 
 

5. Click Yes.  This will make a copy of the image file to your Site folder.  Also, the 
following dialog box will appear: 

 

 
 

6. Click Save.  The image is inserted into the page. 
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Saving the Web Page 
 
1. Click File → Save. 
 
2. The Save As dialog box will appear. 
 
3. In the Save in field, locate the drive and folder where you want to save the file. 
 
4. Enter the name you want to give the file in the File Name field. 
  

NOTE:  For your Home Page (your main webpage, or the first page of a 
multi-page website) must be named “index.htm”.  If you are making more 
than one webpage, then the others may be named anything that ends with 
“.htm”, but the first page must be called index.htm. 

 
5. Click the Save button. 
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Adding a link 
  
A Hyperlink is a colored and underlined text or a graphic that you click to go to a  file, 
web page, or an e-mail address.  To insert a hyperlink to some other website: 
 
1. Type the text you want to make into a hyperlink on your webpage. 
 
2. Select the text. 
 

 
 

• To link to a webpage:  In the Properties Panel click in the Link field and type 
the complete website address (e.g.http://www.kennesaw.edu).  Note that this 
address must include the “http://” portion of the address. 
 

• To link to a file:  In the Properties Panel click on the Yellow Folder  to 
access the Select File screen.  Use this to locate the file that you with to link to.  
After you’ve selected the file to link to, Dreamweaver will ask if you want to 
copy the file to your Site folder – answer Yes to this prompt. 

 
• To link to an e-mail address:  Click in the Link field and preface the email 

address with “mailto:” 
 (e.g. mailto:alincoln@aol.com) 
 
3. Click outside of the Link field in order to complete the process. 
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Linking to another web page 
 
If you make multiple web pages on your own web site, Dreamweaver includes an easier 
way to make links between them. 
 

 
 
1. Create both pages separately and save them in the same Site (e.g. index.htm and 

page2.htm). 
 
2. Make sure that you have the Files panel open, so that you can see the files in your 

Site. 
 
3. Highlight the text you want to make into a link to the other page (e.g. highlight text 

on page2.htm which you want to link to index.htm) 
  
4. Click and Hold the Target Link Icon.  
 
5. Drag the Target Link Arrow to the name of the page that you want to link to, and 

let go of your mouse button. 
 
6. The system will create the link and show the file address in the Link field.   

 
NOTE:  When you make a link to another page in your own web site like 
this, it only puts in the name of the file, and leaves out the 
“http://www.address.com” portion of the address. 
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Previewing 
 
Before you actually put your files on the 
Internet for everyone to see, you might want 
to see what your page looks like in a web 
browser to make sure that nothing looks 
different than you were expecting.  
Dreamweaver makes previewing your pages  
simple: 
 

1. Make sure that the page you want to 
preview is the one that is on the 
screen. 

2. Click on the menu bar:  File → 
Preview in Browser → iexplore 

3. This then opens your page in Internet 
Explorer. 

 
 
 
 
Adding a Browser 
 
However, if you have some other web browser (Netscape, Mozilla, Opera, etc) that you 
want to preview your page in that isn’t on the Preview in Brower list, you first have to 
tell Dreamweaver how to open that program.  To do this, you must: 
 

1. Choose the Edit Browser List… 
option from the Preview in 
Browser list.  This opens the 
Preferences window to the 
Preview in Browser category, as 
shown to the right. 

2. To add a new browser to the list, 
click the + button near the top of 
the screen.  This opens the Add 
Browser screen as shown above. 

3. In the Name field, enter a name which describes the browser that you are adding. 
4. Then click the Browse button to the right of the Application field. 
5. From the Select Browser window, navigate to the executable file for the browser 

(the file which opens the browser).  This file is usually found in a folder inside 
the C:/Program Files folder.  When finished, click OK. 
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Publishing 
 
When your website is at a point that you want to put it on 
the Internet, it is time to publish your website.  Since all of 
your files are already grouped together in your Site in the 
Files section of the toolbar to the right, all you have to do 
is: 
 
1. Click and select the topmost folder of your Site. 
2. Click the Put button        from the Files tab. 
3. If you have any unsaved work, Dreamweaver will 

prompt you to save.  Choose Yes to save your work. 
4. If asked whether to “Include dependent files?” choose 

Yes.  This insures that any files that you linked to are 
included when you send your files to your website. 

 
After these steps are completed, your site will have been 
uploaded to your web space. 
 
*NOTE:  You must set up your Site as detailed on pages 5 
and 6 before you can publish. 
 
 
 
 
Local vs. Remote view 
 
Because of the way that web publishing is done, you end up with copies 
of your web page in two locations:  on your local machine, and on the 
Internet server which hosts your page.  In order to toggle between these 
two views, click on the drop-down box which at first reads Local view.  
The different options we have here are: 
 

 Local view:  Shows the copies of the files for your website which are located on 
your local machine. 

 Remote view:  Shows the copies of the files for your website which are stored on 
the Internet server that is providing access to your site to users. 

 Testing server:  An advanced feature which would show the files which are 
being stored on a test server (We don’t use this feature). 

 Map view:  Shows a visual representation of the interaction between the files that 
make up your website. 
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Many times, it is useful to see the files which are stored on both the local and the remote 
views, to compare and contrast.  To toggle this view on or off, click the 
Expand/Collapse button       on the Files pane.  On the expanded view, you see the 
remote view on the left side of the screen, and the local view on the right side.   
 
*Note:  If there is any difference between the two sites, it could be because you have 
made changes to your site but haven’t used the Put command to upload them yet, or 
because you have worked on a different website before, and that is what you see on the 
remote site. 
 
Viewing Your Website 
 
Your web page can be viewed on any web browser by entering the following address into 
the address bar: 
 
http://students.kennesaw.edu/~yournetID  
 
NOTE:  “yournetID” is your username for the student email system, WebCT, etc. 
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Reconnecting From Another Location 
 
When you want to make changes to your website from 
another location, you first have to connect 
Dreamweaver to your existing site.  Follow the 
instructions on pages 5 and 6 for Defining a Site to 
create a Site which is connected to your existing 
website.  Then, on the Files pane click the Get File(s) 
button        to make a copy of your web site on your 
local computer.  Once you have done this, you are 
prepared to make any changes/additions to your web 
site. 
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